Dependency Convergence

Legend:
[Error] At least one dependency has a differing version of the dependency or has SNAPSHOT dependencies.

Statistics:
Number of dependencies (NOD): 62
Number of unique artifacts (NOA): 73
Number of version-conflicting artifacts (NOC): 8
Number of SNAPSHOT artifacts (NOS): 0
Convergence (NOD/NOA): [Error] 84 %
Ready for release (100% convergence and no SNAPSHOTS): [Error] Error
You do not have 100% convergence.

Dependencies used in this project

com.google.guava:guava

[Error]
16.0.1
    org.everit.osgi.dev:eosgi-maven-plugin:maven-plugin:4.0.0
    \- org.apache.maven:maven-core:jar:3.3.9:provided
       \- com.google.inject:guice:jar:no_aop:4.0:provided
          \- (com.google.guava:guava:jar:16.0.1:provided - omitted for conflict with 18.0)

18.0
    org.everit.osgi.dev:eosgi-maven-plugin:maven-plugin:4.0.0
    \- org.apache.maven:maven-core:jar:3.3.9:provided
       \- org.apache.maven:maven-model-builder:jar:3.3.9:provided
          \- com.google.guava:guava:jar:18.0:provided

commons-logging:commons-logging

[Error]
1.1.1
    org.everit.osgi.dev:eosgi-maven-plugin:maven-plugin:4.0.0
    \- org.apache.maven.doxia:doxia-module-xhtml:jar:1.7:compile
       \- org.apache.maven.doxia:doxia-core:jar:1.7:compile
          \- org.apache.httpcomponents:httpclient:jar:4.0.2:compile
             \- (commons-logging:commons-logging:jar:1.1.1:compile - omitted for conflict with 1.2)

1.2
    org.everit.osgi.dev:eosgi-maven-plugin:maven-plugin:4.0.0
    \- org.everit.expression:org.everit.expression.jexl:jar:2.0.0:compile
       \- org.apache.commons:commons-jexl3:jar:3.0:compile
          \- commons-logging:commons-logging:jar:1.2:compile

junit:junit

[Error]
3.8.1
    org.everit.osgi.dev:eosgi-maven-plugin:maven-plugin:4.0.0
    \- org.apache.maven.doxia:doxia-module-xhtml:jar:1.7:compile
       \- org.apache.maven.doxia:doxia-core:jar:1.7:compile
          \- org.codehaus.plexus:plexus-container-default:jar:1.0-alpha-30:compile
             +- org.codehaus.plexus:plexus-classworlds:jar:2.5.2:compile
             |  \- (junit:junit:jar:3.8.1:compile - omitted for duplicate)
             \- (junit:junit:jar:3.8.1:compile - omitted for conflict with 4.12)

4.12
    org.everit.osgi.dev:eosgi-maven-plugin:maven-plugin:4.0.0
    \- junit:junit:jar:4.12:test (scope not updated to compile)

org.apache.maven:maven-artifact

[Error]
3.0
    org.everit.osgi.dev:eosgi-maven-plugin:maven-plugin:4.0.0
    \- org.apache.maven.plugin-tools:maven-plugin-annotations:jar:3.5:compile
       \- org.apache.maven:maven-artifact:jar:3.0:compile

3.3.9
    org.everit.osgi.dev:eosgi-maven-plugin:maven-plugin:4.0.0
    +- org.apache.maven:maven-core:jar:3.3.9:provided
    |  +- (org.apache.maven:maven-artifact:jar:3.3.9:provided - omitted for conflict with 3.0)
    |  \- org.apache.maven:maven-model-builder:jar:3.3.9:provided
    |     \- (org.apache.maven:maven-artifact:jar:3.3.9:provided - omitted for conflict with 3.0)
    \- org.apache.maven:maven-plugin-api:jar:3.3.9:provided
       \- (org.apache.maven:maven-artifact:jar:3.3.9:provided - omitted for conflict with 3.0)

org.codehaus.plexus:plexus-component-annotations

[Error]
1.5.5
    org.everit.osgi.dev:eosgi-maven-plugin:maven-plugin:4.0.0
    +- org.apache.maven.doxia:doxia-module-xhtml:jar:1.7:compile
    |  +- org.apache.maven.doxia:doxia-core:jar:1.7:compile
    |  |  \- (org.codehaus.plexus:plexus-component-annotations:jar:1.5.5:compile - omitted for duplicate)
    |  \- org.codehaus.plexus:plexus-component-annotations:jar:1.5.5:compile
    \- org.apache.maven:maven-core:jar:3.3.9:provided
       \- org.eclipse.sisu:org.eclipse.sisu.plexus:jar:0.3.2:provided
          \- (org.codehaus.plexus:plexus-component-annotations:jar:1.5.5:provided - omitted for duplicate)

1.6
    org.everit.osgi.dev:eosgi-maven-plugin:maven-plugin:4.0.0
    \- org.apache.maven:maven-core:jar:3.3.9:provided
       +- org.apache.maven:maven-settings-builder:jar:3.3.9:provided
       |  \- (org.codehaus.plexus:plexus-component-annotations:jar:1.6:provided - omitted for conflict with 1.5.5)
       +- org.apache.maven:maven-model-builder:jar:3.3.9:provided
       |  \- (org.codehaus.plexus:plexus-component-annotations:jar:1.6:provided - omitted for conflict with 1.5.5)
       +- org.apache.maven:maven-aether-provider:jar:3.3.9:provided
       |  \- (org.codehaus.plexus:plexus-component-annotations:jar:1.6:provided - omitted for conflict with 1.5.5)
       \- (org.codehaus.plexus:plexus-component-annotations:jar:1.6:provided - omitted for conflict with 1.5.5)

org.codehaus.plexus:plexus-utils

[Error]
1.4.5
    org.everit.osgi.dev:eosgi-maven-plugin:maven-plugin:4.0.0
    \- org.apache.maven.doxia:doxia-module-xhtml:jar:1.7:compile
       \- org.apache.maven.doxia:doxia-core:jar:1.7:compile
          \- org.codehaus.plexus:plexus-container-default:jar:1.0-alpha-30:compile
             \- (org.codehaus.plexus:plexus-utils:jar:1.4.5:compile - omitted for conflict with 3.0.22)

1.5.5
    org.everit.osgi.dev:eosgi-maven-plugin:maven-plugin:4.0.0
    \- org.apache.maven:maven-core:jar:3.3.9:provided
       \- org.sonatype.plexus:plexus-sec-dispatcher:jar:1.3:provided
          \- (org.codehaus.plexus:plexus-utils:jar:1.5.5:provided - omitted for conflict with 3.0.22)

2.0.4
    org.everit.osgi.dev:eosgi-maven-plugin:maven-plugin:4.0.0
    \- org.apache.maven.plugin-tools:maven-plugin-annotations:jar:3.5:compile
       \- org.apache.maven:maven-artifact:jar:3.0:compile
          \- (org.codehaus.plexus:plexus-utils:jar:2.0.4:compile - omitted for conflict with 3.0.22)

3.0.17
    org.everit.osgi.dev:eosgi-maven-plugin:maven-plugin:4.0.0
    \- org.apache.maven:maven-core:jar:3.3.9:provided
       \- org.eclipse.sisu:org.eclipse.sisu.plexus:jar:0.3.2:provided
          \- (org.codehaus.plexus:plexus-utils:jar:3.0.17:provided - omitted for conflict with 3.0.22)

3.0.22
    org.everit.osgi.dev:eosgi-maven-plugin:maven-plugin:4.0.0
    +- org.apache.maven.doxia:doxia-module-xhtml:jar:1.7:compile
    |  +- org.codehaus.plexus:plexus-utils:jar:3.0.22:compile
    |  \- org.apache.maven.doxia:doxia-core:jar:1.7:compile
    |     \- (org.codehaus.plexus:plexus-utils:jar:3.0.22:compile - omitted for duplicate)
    \- org.apache.maven:maven-core:jar:3.3.9:provided
       +- org.apache.maven:maven-model:jar:3.3.9:provided
       |  \- (org.codehaus.plexus:plexus-utils:jar:3.0.22:provided - omitted for duplicate)
       +- org.apache.maven:maven-settings:jar:3.3.9:provided
       |  \- (org.codehaus.plexus:plexus-utils:jar:3.0.22:provided - omitted for duplicate)
       +- org.apache.maven:maven-settings-builder:jar:3.3.9:provided
       |  +- org.apache.maven:maven-builder-support:jar:3.3.9:provided
       |  |  \- (org.codehaus.plexus:plexus-utils:jar:3.0.22:provided - omitted for duplicate)
       |  \- (org.codehaus.plexus:plexus-utils:jar:3.0.22:provided - omitted for duplicate)
       +- org.apache.maven:maven-repository-metadata:jar:3.3.9:provided
       |  \- (org.codehaus.plexus:plexus-utils:jar:3.0.22:provided - omitted for duplicate)
       +- org.apache.maven:maven-model-builder:jar:3.3.9:provided
       |  \- (org.codehaus.plexus:plexus-utils:jar:3.0.22:provided - omitted for duplicate)
       +- org.apache.maven:maven-aether-provider:jar:3.3.9:provided
       |  \- (org.codehaus.plexus:plexus-utils:jar:3.0.22:provided - omitted for duplicate)
       \- (org.codehaus.plexus:plexus-utils:jar:3.0.22:provided - omitted for duplicate)

org.eclipse.aether:aether-api

[Error]
1.0.2.v20150114
    org.everit.osgi.dev:eosgi-maven-plugin:maven-plugin:4.0.0
    \- org.apache.maven:maven-core:jar:3.3.9:provided
       +- org.apache.maven:maven-aether-provider:jar:3.3.9:provided
       |  +- (org.eclipse.aether:aether-api:jar:1.0.2.v20150114:provided - omitted for duplicate)
       |  \- org.eclipse.aether:aether-spi:jar:1.0.2.v20150114:provided
       |     \- (org.eclipse.aether:aether-api:jar:1.0.2.v20150114:provided - omitted for duplicate)
       +- org.eclipse.aether:aether-impl:jar:1.0.2.v20150114:provided
       |  \- (org.eclipse.aether:aether-api:jar:1.0.2.v20150114:provided - omitted for duplicate)
       +- (org.eclipse.aether:aether-api:jar:1.0.2.v20150114:provided - omitted for conflict with 1.1.0)
       \- org.eclipse.aether:aether-util:jar:1.0.2.v20150114:provided
          \- (org.eclipse.aether:aether-api:jar:1.0.2.v20150114:provided - omitted for duplicate)

1.1.0
    org.everit.osgi.dev:eosgi-maven-plugin:maven-plugin:4.0.0
    \- org.eclipse.aether:aether-api:jar:1.1.0:compile

org.everit.templating:org.everit.templating.api

[Error]
1.0.0
    org.everit.osgi.dev:eosgi-maven-plugin:maven-plugin:4.0.0
    \- org.everit.templating:org.everit.templating.text:jar:1.1.1:compile
       \- org.everit.templating:org.everit.templating.util:jar:1.0.0:compile
          \- (org.everit.templating:org.everit.templating.api:jar:1.0.0:compile - omitted for conflict with 1.1.0)

1.1.0
    org.everit.osgi.dev:eosgi-maven-plugin:maven-plugin:4.0.0
    +- org.everit.templating:org.everit.templating.text:jar:1.1.1:compile
    |  \- org.everit.templating:org.everit.templating.api:jar:1.1.0:compile
    \- org.everit.templating:org.everit.templating.html:jar:1.2.0:compile
       \- (org.everit.templating:org.everit.templating.api:jar:1.1.0:compile - omitted for duplicate)